主题 : linux-2.6.38到tiny6410的移植手册(连载1)__nand flash 复制链接 | 浏览器收藏 | 打印
级别: 新手上路
UID: 63828
精华: 0
发帖: 14
金钱: 70 两
威望: 14 点
贡献值: 0 点
综合积分: 28 分
注册时间: 2012-02-25
最后登录: 2012-03-21
40楼  发表于: 2012-03-07 15:38
谢谢楼主了
级别: 新手上路
UID: 63021
精华: 0
发帖: 27
金钱: 135 两
威望: 27 点
贡献值: 0 点
综合积分: 54 分
注册时间: 2012-02-12
最后登录: 2012-05-26
41楼  发表于: 2012-03-09 15:38
qin~~
好厉害啊~~
级别: 新手上路
UID: 65510
精华: 0
发帖: 15
金钱: 75 两
威望: 15 点
贡献值: 0 点
综合积分: 30 分
注册时间: 2012-03-19
最后登录: 2017-09-13
42楼  发表于: 2012-03-22 17:09
   very good
级别: 侠客
UID: 60773
精华: 0
发帖: 79
金钱: 395 两
威望: 79 点
贡献值: 0 点
综合积分: 158 分
注册时间: 2011-12-16
最后登录: 2013-07-11
43楼  发表于: 2012-03-30 22:59
        
级别: 新手上路
UID: 66370
精华: 0
发帖: 2
金钱: 10 两
威望: 2 点
贡献值: 0 点
综合积分: 4 分
注册时间: 2012-03-29
最后登录: 2012-04-18
44楼  发表于: 2012-04-13 15:45
arm-linux-ld: error: Source object drivers/mtd/nand/s3c_nand_mlc.fo has EABI version 5, but target drivers/mtd/nand/built-in.o has EABI version 0
arm-linux-ld: failed to merge target specific data of file drivers/mtd/nand/s3c_nand_mlc.fo
make[3]: *** [drivers/mtd/nand/built-in.o] 错误 1
make[2]: *** [drivers/mtd/nand] 错误 2
make[1]: *** [drivers/mtd] 错误 2
make: *** [drivers] 错误 2

这可怎么办啊?
级别: 新手上路
UID: 66987
精华: 0
发帖: 13
金钱: 65 两
威望: 13 点
贡献值: 0 点
综合积分: 26 分
注册时间: 2012-04-06
最后登录: 2012-04-23
45楼  发表于: 2012-04-15 16:51
haoya
级别: 新手上路
UID: 37613
精华: 0
发帖: 11
金钱: 55 两
威望: 11 点
贡献值: 0 点
综合积分: 22 分
注册时间: 2011-02-13
最后登录: 2012-07-19
46楼  发表于: 2012-07-10 16:06
请问drivers/mtd/nand/s3c_nand_mlc.fo这个文件在哪可以找到,谢谢
级别: 新手上路
UID: 32897
精华: 0
发帖: 31
金钱: 155 两
威望: 31 点
贡献值: 0 点
综合积分: 62 分
注册时间: 2010-11-23
最后登录: 2013-02-28
47楼  发表于: 2012-08-08 20:58
不错呀
级别: 圣骑士
UID: 44407
精华: 0
发帖: 388
金钱: 1945 两
威望: 389 点
贡献值: 0 点
综合积分: 776 分
注册时间: 2011-04-25
最后登录: 2014-08-25
48楼  发表于: 2012-08-28 12:49
引用第45楼ss5153于2012-04-13 15:45发表的  :
arm-linux-ld: error: Source object drivers/mtd/nand/s3c_nand_mlc.fo has EABI version 5, but target drivers/mtd/nand/built-in.o has EABI version 0
arm-linux-ld: failed to merge target specific data of file drivers/mtd/nand/s3c_nand_mlc.fo
make[3]: *** [drivers/mtd/nand/built-in.o] 错误 1
make[2]: *** [drivers/mtd/nand] 错误 2
make[1]: *** [drivers/mtd] 错误 2
.......


比較友善的make menuconfig 的Kernel Features項目,少  [*] Use the ARM EABI to compile the kernel  

                
  Kernel Features  --->  
[*] Use the ARM EABI to compile the kernel                      
[*]   Allow old ABI binaries to run with this kernel (EXPERIMENTA  
级别: 新手上路
UID: 77847
精华: 0
发帖: 27
金钱: 135 两
威望: 27 点
贡献值: 0 点
综合积分: 54 分
注册时间: 2012-09-12
最后登录: 2013-04-22
49楼  发表于: 2012-09-20 18:45
lz好厉害啊 学习一下